Bidding halted, Administration interface down
Incident Report for BidTheatre
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 16:05 CET
Investigating
We are experiencing a system issue that affects bidding and the administration interface. Our platform team is working with the highest effort to restore services, and we will keep you posted.
Posted Feb 20, 2020 - 15:37 CET
This incident affected: Bidding and Administration interface.