Bidding halted due to statistics lag
Incident Report for BidTheatre
Resolved
This incident has been resolved
Posted Jul 24, 2018 - 10:45 CEST
Identified
An internal check has indicated that hourly statistics has not been computed within standard time limits. As a precaution, bidding has been halted. We are investigating the issue and will update shortly.
Posted Jul 24, 2018 - 08:52 CEST
This incident affected: Bidding.